21 févr. 2009

Erreur d'update d'apt-get

Si vous aussi vous avez rajouté des dépots dans votre sources.list et quand vous faites un raffraichissement de la base d'apt-get vous recevez une erreur de ce style:

W: GPG error: http://ppa.launchpad.net intrepid Release: Les signatures suivantes n'ont pas pu être vérifiées car la clé publique n'est pas disponible : NO_PUBKEY FC66403D8670A035

Le problème c'est que votre clée publique pour accéder a la liste des majs des paquets n'est plus valide, et qu'il faut la retélécharger. Pour cela:

  1. gpg --keyserver hkp://keyserver.ubuntu.com:11371 --recv-key 8670A035
  2. gpg -a --export 8670A035 | sudo apt-key add -

Et il suffit de raffraichir avec un update votre apt-get, tout se passera mieux ^^.

Plus généralement, j'ai vu sur un autre site qui expliquait comment retélécharger les clées gpg directement en fonction de la clée publique qui vous fait défaut.
Dans le message d'erreur, les 8 derniers caractères sont a recopier dans la commande i) comme je l'ai fait pour mon erreur.

Voilà ;)

Aucun commentaire: